Peakto Face Analysis keeps "sticking" after 1-2 hours on a large Lightroom catalogue

Peakto Face Analysis keeps "sticking" after 1-2 hours on a large Lightroom catalogue

I upgraded to Peakto 2.0.1 today (from 1.12). I decided to (re)run a deep analysis of my Lightroom catalogue to make sure all was up-to-date. Then my problems started when Peakto got  to its "AI" analysis...

(info: running on an M1 Max MacBook Pro with 64GB RAM, using a 10Gbps USB 4TB external SSD to hold my Lightroom catalogue of about 60,000 images)

I'm on my second try at this. Peakto 2 runs the 1st AI pass (how "artistic" my images are) in a reasonable time (less than 30 minutes I think). Then it says "Complete Face Analysis in Lightroom Catalog-xxxxx" and slowly progresses the percentage over a long time. The first run it got to "40%" and then sat there without changing for an hour. I killed the analysis and tried "Complete Face Analysis" which did not access the catalog at all; ditto when I tried "Compute Missing AI and Faces" - in both cases there is no pop-up progress window, and the catalogue disk is apparently not accessed (it has a status LED, at least for writes).

For this 2nd run I again restarted Peakto 2 and went "Run AI Analysis and Faces", which caused the "artistic" quality to be re-evaluated, and now the "Extracting Faces" progress is stuck on "32%". Peakto briefly accesses the external catalog disk every 30-60 seconds for about 2 seconds each time. It's been sitting at 32% for about 2 hours now without progressing.

Also the AI subject detection is hugely incomplete; for example I went and searched for "spiders" and Peakto had only found 5 images out of very many spider images.

So right now I wish I was back on Peakto v1, which worked for me.

Can someone please explain what I'm doing wrong? Or is this a problem with Peakto v2? it's not much use if it can't actually use the AI!

I should note that I had no such issues with Peakto v1.

Regards, M.